WP_White&Green_Transparant

Website Crashes & Fatal Errors Caused By Yoast SEO 19.7

Website Crashes & Fatal Errors Caused By Yoast SEO 19.7

A fatal error conflict was found in Yoast SEO for WordPress version 19.7, which was causing websites to crash.

Already Yoast’s upgrade has failed three times this year due to incompatibilities with other plugins.

The good news is that Yoast looked into the complaints and released an update to address the issues quickly.

Why Do WordPress Fatal Errors Occur?

There might be many reasons for a fatal error to occur, but in this case, it was due to a coding clash introduced by a recent update to Yoast SEO. This occurred with the release of Yoast 19.7.

This can arise if two plugins, both attempting to do the same task, are mutually inhibiting their performance.

A plugin conflict could be compared to two vehicles that are traveling in opposite directions on a one-way street.

A well-written plugin should be able to coexist with other plugins, especially widely-used ones, without interfering with their functionality.

Other plugins (or custom code) that alter the admin login URL were incompatible with Yoast 19.7.

The purpose of changing the login URL is to mislead automated hacking tools that try to guess the login password by going to the default URL for administrator logins.

Bug Updated Announced By Yoast

Yoast was completely forthright about the issue, providing a detailed explanation to its users.

In a tweet, Yoast announced:

“After the release of Yoast SEO 19.7, we were informed that this version causes a fatal error when used in combination with plugins or code that alters the default WordPress login URL.

We’ve identified the problem and are working on a solution.”

According to the Yoast plugin development changelog, version 19.7 contained a change that would stop Yoast from functioning on the login page if a fatal error occurred.

“Improves the handling of fatal errors in the front-end by preventing Yoast SEO to run in the login page, allowing users to access their dashboard.”

The Reason Why Fatal Errors Happen With Plugins

Yoast isn’t the only plugin that can cause issues. Yoast’s massive user base means that incidents like this get more attention.

This is the third Yoast plugin update this year that has been linked to a fatal error plugin conflict.

It’s not always possible to account for the thousands of plugins in the WordPress ecosystem with which a coding conflict could occur, as Yoast SEO Plugin inventor Joost De Valk said in a tweet.

“This is the sort of #WordPress plugin conflict situation that I literally don’t know how to prevent from happening.

60,000+ plugins: how do you test your plugin against all of those.

If someone has good ideas, I’m all ears.”

Furthermore, Joost noted that Yoast always thoroughly tests plugin upgrades with a wide variety of plugins before making them available to the public.

“We test against the big ones, not worried about those as much, but a couple small ones together still cause enough of a headache.”

He also went on to say that:

“…it’s never fun when you break stuff. We test very rigorously and still stuff goes through. Building plugins for large amounts of users is “just” hard.”

Solutions and Recommendations

Two hours after declaring that they had found a flaw in the upgrade and were working on a fix, Yoast released a new update.

We’ve resolved the problem and released a patch. You can now safely update to Yoast SEO 19.7.1.

We’ve marked the incident report at https://t.co/sBvJewCAeX as resolved.

— Yoast (@yoast) September 20, 2022

The latest version of Yoast is 19.7.1. This was written in the Yoast development changelog:

“Fixes a bug where a fatal error would be thrown in combination with certain plugins that change the standard login page URL.”

Users of the Yoast SEO plugin should think about upgrading to the newest version, 19.7.1.

About Us

Our weekly updates provide you with industry expert insights and breaking news so you are always up to date.

Recent Posts